Announcement

Collapse
No announcement yet.

Runtime error 217

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Runtime error 217

    Hello all,

    I posted this on techtalk but will here as well since it was suggested and makes more sense.

    Here is my original thread:
    http://techtalk.parts-express.com/fo...-runtime-error

    Long story short is OM used to work before switching from windows 7 to 10. Now it will not launch or even test compatibility without giving the runtime 217 error. I have tried so many things it's crazy with no luck. OM is the only program on the computer that prompts this issue. Any suggestions are greatly appreciated!

    Thanks
    Last edited by dynamo; 01-24-2017, 11:19 AM. Reason: forgot a word

  • #2
    I don't have this problem with my installation on Win10, and certainly don't need to run the software in compatibility mode for it to work under Win10 either. I'd suggest running a google search for your "runtime error 217" and see if any of the suggestions help.

    https://www.google.ca/search?q=runti...zRCMPbjwTo7bJo
    "I just use off the shelf textbook filters designed for a resistor of 8 ohms with
    exactly a Fc 3K for both drivers, anybody can do it." -Xmax

    Comment


    • #3
      Thanks, I've tried so many of those things with no luck..

      Comment


      • #4
        Have you installed the anniversary edition of Windows 10 yet? If not try that. I've had to do this on a few machines with strange unfixable problems. Windows 10 has been a major disappointment.

        Comment


        • #5
          Is that a free download from Microsoft? I "upgraded" from 7, so is it something that I am eligible for? Thanks

          Comment


          • #6
            Yes absolutely free.

            Comment


            • #7
              I have the same problem on one of my computers. I upgraded from Windows 7 to 10 on both my laptop and desktop. Omnimic worked fine on both with Windows 7.

              My desktop with Windows 10 still runs Omnimic with no issues. I use this install for post processing and making plots for documents or exporting results for another program.

              On my laptop, which I use for all measurements, I immediately got the 217 error. No idea why or how to fix it, I searched the Internet. The error does not occur with an install of my original Omnimic disk from a few years ago. But for any of the downloaded upgrades the 217 error is back. I have tried all kinds of things to get rid of the error. Then one night I just restarted the laptop and when it came back up everything worked again. So when I want to run Omnimoc and make measurements with my laptop I turn it on, wait a few minutes, and then do a restsrt. Stupid but it works for me every time.

              Hope that helps.
              Martin

              Quarter Wavelength Loudspeaker Design
              www.quarter-wave.com

              Comment


              • #8
                Thanks, unfortunately the restart doesn't help on mine. I still need to try the anniversary edition yet.

                Comment


                • #9
                  Originally posted by SHYNOLA View Post
                  Have you installed the anniversary edition of Windows 10 yet? If not try that. I've had to do this on a few machines with strange unfixable problems. Windows 10 has been a major disappointment.
                  *****THIS*****

                  It worked. I downloaded the x64 version of the anniversary update and restarted and still no go. I uninstalled Omnimic and ran CCleaner. I restarted and went to the Dayton website and redownloaded the latest version and reinstalled it, and restarted again. And it opened! Thank you and everybody who gave suggestions!

                  Comment


                  • #10
                    Nothing worked for me. I bought a new dell laptop just to run this software (older laptop is dedicated to running the CNC) and Windows 10 is what you get now. Nothing I've tried works. Reinstalling, running as admin, and running in any number of compatibility modes have no effect - still gets the 217 error. All other software runs just fine. The developer of this software needs to fix it.

                    Comment

                    Working...
                    X