Announcement

Collapse
No announcement yet.

Omg !!! 😀

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wolf
    replied
    Those are either EAR or Decidamp2 plugs.
    Later,
    Wolf

    Leave a comment:


  • djg
    replied
    Click image for larger version

Name:	e a r.jpg
Views:	462
Size:	22.5 KB
ID:	1432372

    Leave a comment:


  • Dukk
    replied
    Excellent. Great to hear that you figured out what the issue was.

    Leave a comment:


  • Fishchris
    replied
    🙂 Serious though, this significantly shortens my list of "stereo things to do".

    I am going to get that DSP + mic ASAP....
    And a 4 ch amp, so I can completely retire that old RF Power 1000 25 to Life.....

    And their is this one more little bass related thing.... But I'll talk about that a lot more as that time nears 😉 ......and that might require some power upgrades.

    Still though, my long term stereo plans went from about $2500 to $1200 😉 Easy peasy.... That's like one good weekend of driving....

    Leave a comment:


  • Chris Roemer
    replied
    w - h - a - a - a - t ?

    (imagine the above as all upper case, that's how I typed it, but the forum "editor" doesn't seem to like my "yelling" either, I guess ... )

    Leave a comment:


  • Fishchris
    started a topic Omg !!! 😀

    Omg !!! 😀

    I'm freaking beside myself 😀

    That new box of mine that I previously rated an 8.5 or 9 out of 10 ? ...
    Well.... No....

    That freaking thing is a 12 out of 10 ! 😀 Okay so first off, I'm just going to throw this out there, because it is what it is.....
    I'm retarded 😆 That popping that started back with the Isobaric 15"s ? A freaking loose power cable ! How did I freaking miss that ! Fixed that, and was able to beat the chit out of it, with zero popping, or any kind of bad sounds for that matter....

    But that only lasted for about 15 minutes, because then I started putting in that new Wolfram 2400.1 and just WoW ! It was hard to clip that thing ! At a few points with just some really loud kick drums, I saw just some really quick flickers... But it was so loud by that point it was scary ! 😆 Lol
    I can't imagine playing a continuous bass tone in the 38 to 45 hz range, so loud that it clipped continually...

    I played crazy 20 hz test tones, and a few old school rock songs, and it all sounded fantastic 🙂

    BTW, I always wondered if my mids and highs would play louder and cleaner, if the bass channel of that 5 ch amp was not being used ? And the answer is, WAY louder and cleaner ! In fact, it was hard to make that clip now too !

    Long story short, I was out for about 40 minutes of testing... Managed to make my ears ring, and neither amp ever got warm, nor did my voltage ever dip below 13.4 🙂 And I was just parked.
    Driving, it will probably hold 14 volts solid, while beating hard on the stereo 🙂

    Freaking thrilled ! 🙂

    Definitely the loudest, deepest, cleanest system I've ever had 🙂 Whooo-freaking-hooo ! 🙂
Working...
X