Announcement

Collapse
No announcement yet.

Broken Sub Channel

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Broken Sub Channel

    So I bought on of these 2.1 Class D amps and finally got around to playing with it. While I had it plugged in with music, I took out my multi-meter and started playing; "What happens if I touch this?". Well when I hit the positive/negative terminals on the the sub channel, that channels went silent. Now it just makes a steady, faint click noise.

    Any idea what I broke and how I could go about diagnosing it and fixing it? The best way to learn about something is to break it then fix it right?

    BTW, I'm really blown away by how this thing sounds.
    Buy SainSmart 12V 50Wx2+100W TPA3116D2 2.1 HIFI Digital Subwoofer Amplifier Verst Board: Motherboards - Amazon.com ✓ FREE DELIVERY possible on eligible purchases

  • #2
    Chip amps like that have very little going on other than the TDA3116D2 IC itself. Not sure what you may have done, blown the chip or disturbed a flakey solder joint. For the solder, you could remove the heat sink and inspect it under magnification looking for any cracks or bad solder joints. If it's the chip you're pretty much hosed. That's a pretty cheap assembly and the reviews seem to indicate some mixed quality control. It's actually easier to find more of those pre-built boards than it is a replacement chip based on a casual search.

    ​Also, those specs are really optimistic. The chip is rated for 50W per channel into 4 ohms with a 24V supply. I have no idea where they're getting the 100W sub channel, there must be a second chip on board but there's no way to bridge a chip. That said, you can get some good sound out of these little class D amps these days, so I have no doubt it sounded fine.
    Electronics engineer, woofer enthusiast, and musician.
    Wogg Music

    Comment


    • #3
      Originally posted by wogg View Post
      Chip amps like that have very little going on other than the TDA3116D2 IC itself. Not sure what you may have done, blown the chip or disturbed a flakey solder joint. For the solder, you could remove the heat sink and inspect it under magnification looking for any cracks or bad solder joints. If it's the chip you're pretty much hosed. That's a pretty cheap assembly and the reviews seem to indicate some mixed quality control. It's actually easier to find more of those pre-built boards than it is a replacement chip based on a casual search.

      ​Also, those specs are really optimistic. The chip is rated for 50W per channel into 4 ohms with a 24V supply. I have no idea where they're getting the 100W sub channel, there must be a second chip on board but there's no way to bridge a chip. That said, you can get some good sound out of these little class D amps these days, so I have no doubt it sounded fine.

      The 100 W sub channel rating presumes a 2 ohm sub. At 24 V you can get ~70 W rms per channel (a 4 ohms) and ~!40 W rms (2 ohm sub). The 2 x 50 W + 100W is the thermal dissipation limit of the chip. But those wattage ratings are for a sine wave. Music is never as dense as a sine wave so less heat is dissipated over time. You effectively have a 2 x 70 W + 140 W amp.

      Comment


      • #4
        Originally posted by DRD2 View Post
        I took out my multi-meter and started playing; "What happens if I touch this?". Well when I hit the positive/negative terminals on the the sub channel, that channels went silent. Now it just makes a steady, faint click noise.
        Any burnt/bulging components in the output filter (everything after the chip up to the speaker terminals (check the underside as well)? What did you have the meter set for (volts, amps, ohms, etc.)?


        Comment


        • #5
          Nothing burnt, no smoke or discolored markings. I had the meter set to volts, I think...

          Comment


          • #6
            Originally posted by DRD2 View Post
            Nothing burnt, no smoke or discolored markings. I had the meter set to volts, I think...
            If you "think", you are not sure. If you had your multimeter set to amps, you created a direct short!
            Don't worry, if your parachute fails, you have the rest of your life to fix it.

            If we all did the things we are capable of doing, we would literally ASTOUND ourselves - Thomas A. Edison

            Some people collect stamps, Imelda Marcos collected shoes. I collect speakers.:D

            Comment


            • #7
              Originally posted by thekorvers View Post

              If you "think", you are not sure. If you had your multimeter set to amps, you created a direct short!
              Why I asked ...

              At the price of these amps, I'd just re-purchase it from the same vendor (I did when I torched one). I am using the same amp (albeit the 1 PS Cap version). The sub channel is a fixed 2nd order LP circa 100 hz (if the board was populated with the correct parts). That's easy to change by replacing the two box poly caps between the op-amps on the board. I have the equations if you interested.

              See this post for a full discussion this amp family.

              http://techtalk.parts-express.com/fo...-modifications

              Comment

              Working...
              X