Announcement

Collapse
No announcement yet.

Klipsch AW650

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Klipsch AW650

    My Buddies Klipsch AW650 are blown/frozen. I would like advise on how/what to check to fix them.
    His amp works fine, only low volume is produced from the speakers.

  • #2
    Two of them? Used outside? How old? Used "strenuously"?

    Comment


    • #3
      yes both of them used outside, for about 3 years. I was told Guests had stereo at full volume most the day then PFFFT out it went. Most other times, it was low level play.

      Comment


      • #4
        Odd they both went at once. Do they have fuses?
        Francis

        Comment


        • #5
          If it was a fuse, I'd expect no output, not low volume. Could the voice coils both have come out of the gaps or frozen if they were driven at high volume? Maybe you could just see if the cones can be moved in and out with your fingers.

          Comment


          • #6
            How do you know the amp is fine?

            Comment


            • #7
              Maybe they've got PTC protection and that's been damaged. Open them up and look for a small flat circular yellow component on the x-over's circuit board. Some speakers only have protection on the tweeter, others have this type of protection in place for both drivers.
              Brian Steele
              www.diysubwoofers.org

              Comment


              • #8
                Ok, thank you. They require a long Star drive to open. Part of the reason I was asking. I will test each driver to see if they move and look in side once I get them open.

                Comment


                • #9
                  After some testing. The bass drivers are fine, but the tweeters are producing no sound. I will next test each tweeter with out the crossover connected. I will do this at low volume.

                  Comment


                  • #10
                    Another update, I tested the tweeter NO sound. ZERO under any amount of volume. So I believe its the tweeter. If others agree, I will need to know a replacement. The only numbers I see on it is 02DT4283. Any ideas of a replacement?

                    Comment


                    • #11
                      Maybe Klipsch offers replacements? But the woofers are OK?
                      Francis

                      Comment


                      • #12
                        There is a forum for Klipsch owners and products, try there?

                        Comment


                        • #13
                          I think you are looking for Klipsch part #1006891. About $37, but not seeing them in stock after a quick search.
                          My Builds - Vigor (Nola Brio Knockoff) - Overnight Sensations w/ Voxel - Speedsters in surplus boxes - Zaph B3N's in bamboo - Classix II in BR-1 cabinets - Dual TPA3116 D2 amp in an old music box - Mariposas

                          Comment


                          • #14
                            Thank you all for your help and suggestions. I ordered used Klipsch tweeters from ebay. $8 each Ill see if those works.

                            Comment

                            Working...
                            X