Announcement

Collapse
No announcement yet.

Blue Icicle replacement :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blue Icicle replacement :(

    So my Blue Icicle is not being recognized by Windows on any computer in the house, so I'm confirming by various Google searches that it's dead.

    I need a replacement, I'd like to step it up a notch and get a nicer USB mixer/mic preamp

    Any recommendations?

    रेतुर्न तो थे स्रोत
    return to the source
    leviathan system thread
    deadhorse thread
    shockwave build thread

    instagram :: greywarden_13

    in war, victory . . . in peace, vigilance . . . in death, sacrifice.

  • #2
    Re: Blue Icicle replacement :(

    I like the m-audio stuff. Built in preamp, different models available.

    I have the old style Avid unit
    John H

    BR-2, Titan OB, B452, Udique, Vultus, Latus1, Seriatim ,Aperivox,

    Comment


    • #3
      Re: Blue Icicle replacement :(

      Don't give up that easily. There's a glitch that might be causing your problem. Don't let windoze instal any drivers for the Blue Icicle and it should be fine.

      Basically you need to locate the incorrect installed device in device manager and uninstall that first. Then you'll be starting from scratch. Plug the Blue Icicle in and as soon as you get that pop-up box from windoze that tries to automatically install the "correct driver" LOL....terminate that process. Just say no.

      I had this issue with my WIN-7(64) machine. I did not have the issue with WinXP pro.

      Does this make sense? Did you read about this glitch at all? It's legit.
      Bryan K.

      Midwest Audio Club

      Speedster | Sub Attachť | The Wildeman | Sean's NLA Towers | CO‹GAR, COUGAR II and CO‹GAR JR | Triton | Lithium | J-Boom | Trym MLTL | Docere MLTL

      Comment


      • #4
        Re: Blue Icicle replacement :(

        Go into Device manager.
        If you see "USB Multi-channel audio" device listed, then you have the windows driver problem.

        Unplug the blue icicle.

        Go into WIN device manager and unistall the USB Multi-channel audio device.

        Plug the blue icicle back into a USB port. As soon as windows tries to automatically install the driver, terminate that process.

        Check device manager again and you should see the Blue Icicle listed correctly without any warning signs. It may help to reboot as well.
        Bryan K.

        Midwest Audio Club

        Speedster | Sub Attachť | The Wildeman | Sean's NLA Towers | CO‹GAR, COUGAR II and CO‹GAR JR | Triton | Lithium | J-Boom | Trym MLTL | Docere MLTL

        Comment


        • #5
          Re: Blue Icicle replacement :(

          False Alarm

          Mr. Keane (aka Jesus) brought my Blue Icicle (aka Lazarus) back from the dead.

          You have to open up the device manager

          Expand the "Sound" section

          right click the "multichannel...."

          Make sure your Blue Icicle is unplugged

          and click "uninstall"

          Next, plug it back in - and be quick

          you have to click the little triangle at the bottom right corner and you'll see windows "installing" these incorrect drivers

          STOP IT (don't click "close" click the other sentence that is clickable)

          It should work after this, you may have to a couple times to get it to work.

          रेतुर्न तो थे स्रोत
          return to the source
          leviathan system thread
          deadhorse thread
          shockwave build thread

          instagram :: greywarden_13

          in war, victory . . . in peace, vigilance . . . in death, sacrifice.

          Comment


          • #6
            Re: Blue Icicle replacement :(

            LOL....yeah that's it. I remember now. It did take me a couple times to get it right as well. The short of it is that you DO NOT want windows to install what it thinks is the right driver for the Blue Icicle. In fact, it needs no driver at all and that's how you need to install it the first time. Once you're successful, you should not have a problem going forward as long as you use the same USB port. I'm not absolutely positive on this one, but I believe the Blue Icicle or windows has device port memory here. So if you utilize a different USB port, it will once again do an incorrect windows driver install and fudge everything up.

            Glad it worked for you my son. ...LOL
            Bryan K.

            Midwest Audio Club

            Speedster | Sub Attachť | The Wildeman | Sean's NLA Towers | CO‹GAR, COUGAR II and CO‹GAR JR | Triton | Lithium | J-Boom | Trym MLTL | Docere MLTL

            Comment


            • #7
              Re: Blue Icicle replacement :(

              I tried using HOLM on my newer Win8 laptop this weekend, and my measurements were cRaZy. Wonder if I'm having a similar issue caused by incorrect Blue Icicle drivers?

              Comment


              • #8
                Re: Blue Icicle replacement :(

                I wasn't even able to make measurements with mine. I could attempt to try that out on my Win8 rig this weekend.

                रेतुर्न तो थे स्रोत
                return to the source
                leviathan system thread
                deadhorse thread
                shockwave build thread

                instagram :: greywarden_13

                in war, victory . . . in peace, vigilance . . . in death, sacrifice.

                Comment


                • #9
                  Re: Blue Icicle replacement :(

                  Glad the windows and the blue icicle are cooperating again.

                  Comment


                  • #10
                    Re: Blue Icicle replacement :(

                    Originally posted by 50 watt head View Post
                    I tried using HOLM on my newer Win8 laptop this weekend, and my measurements were cRaZy. Wonder if I'm having a similar issue caused by incorrect Blue Icicle drivers?
                    Could be the drivers. Another thing to try is calibrating your sound card in Holm. Also, your mic is calibrated too?

                    Comment

                    Working...
                    X