No announcement yet.

Omnimic runtime error 217 at 00028252

  • Filter
  • Time
  • Show
Clear All
new posts

  • Omnimic runtime error 217 at 00028252

    Dear all,
    Have been using Omnimic on my Win10 Laptop no problem.

    Did a clean install using the latest MS Win10 install from a USB to freshen up.

    Now I have installed Omnimic using latest versions from Dayton and PE (they seem like slightly different versions) and I get this nasty error.

    I've tried reinstalling Omnimic 3 times. Run antivirus twice (quick and full offline scans) and still have this problem.

    I also tried the CCleaner trick listed here but still get this runtime error!

    Here is the Event Viewer log:

    General Desc:
    Faulting application name: OmniMic.exe, version:, time stamp: 0x2a425e19
    Faulting module name: unknown, version:, time stamp: 0x00000000
    Exception code: 0x00000000
    Fault offset: 0x00000000
    Faulting process id: 0x758
    Faulting application start time: 0x01d52670d04d6a4b
    Faulting application path: C:\Program Files (x86)\OmniMic\OmniMic.exe
    Faulting module path: unknown
    Report Id: 2319923b-d6db-4cb1-9463-145c4f42fa49
    Faulting package full name:
    Faulting package-relative application ID:

    XML Details:
    - <Event xmlns="">
    - <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2019-06-19T07:30:05.476970000Z" />
    <Security />
    - <EventData>
    <Data>C:\Program Files (x86)\OmniMic\OmniMic.exe</Data>
    <Data />
    <Data />

    Any help appreciated.

    Last edited by Maz; 06-19-2019, 04:01 AM.
    Klipsch KG 5.5 update.....

  • #2
    Hi Maz,

    I'm sorry you're having this problem. I have only ever had this issue when trying to run Omnimic in safemode, which leads me to believe there is something like a .dll file that Windows is having trouble accessing / finding. You mention running antivirus software, did you happen to try running Omnimic before you loaded whatever antivirus you have, and also which software is it? Potentially your antivirus is inhibiting Omnimic from finding what it needs.

    You also might want to try running it in safe mode to see what happens and report back your findings.

    The DLL files necessary for Omnimic to run are ntdll.dll, wow64.dll, wow64win.dll, wow64cpu.dll. If you look these up individually you might find your answer there.

    Best of luck.
    Parts Express Engineer


    • #3
      Hi Jason,
      Many thanks for your reply.

      The process I went through has gone something like this:

      1) I looked through the MS community and followed a few very detailed fix walk throughs:
      Following the advice in this thread I ran the offline Windows Defender Antivirus scan. I have not installed any third party antivirus.

      As recommended in these support threads I tried booting in safe mode. Running Omnimic in safe mode returned exactly the same error.

      I also tried each compatability mode - same error.

      None of the recommendations seemed to have any affect. The same error occurs.

      2) Next I did a roll back to the clean install by using the Win 10 "Reset this PC" function in the Recovery page of control panel.

      I re-downloaded the Omnimic software and installed it prior to adding any other software and I still get the same error.

      3): In utter exasperation I have completely re-reinstalled Windows 10. I have spent the last day downloading a heap of updates until Windows Update reported my system was fully up to date. I've installed nothing else onto my Dell Inspiron 5555 laptop other than Omnimic and I still get this error!


      Its too late here now to investigate the .dll's you have kindly mentioned so I will seek those out tomorrow and report back.

      Thanks again.
      Last edited by Maz; 06-21-2019, 02:16 AM.
      Klipsch KG 5.5 update.....


      • #4
        I figured that worst case scenario you would have to reinstall windows and that would fix it. I am surprised that did not resolve your problem.

        I recommend re-downloading Windows 10, and trying to reinstall again with a completely different flash drive, assuming you used the same one for your most recent reinstall. Flash drives can be finicky, somaybe somehow that was your problem.

        Otherwise I wonder if there is some sort of permission error. Did you install OmniMic to the typical C:\Program Files (x86) \ OmniMic folder? You are using a user account with full permissions as well?
        Parts Express Engineer


        • #5
          Hi Jason,
          Thanks for hanging in here with me.

          For each install of Omnimic I simply left it to install in the default file location. I am using the administrator account for this machine.

          Regarding the clean install process I have been through, I probably needed to be more specific in my earlier post, so I'll try to add some detail here....

          1) The first clean install I performed MS calls a "Clean install of Windows 10 using installation media" Following the steps there I clean installed from a bootable USB.

          Once the install completed, first I installed all my device hardware drivers. Then I installed my audio apps.

          All of my apps worked fine; WinISD, Hornresp, DATS, XSim, REW etc. all EXCEPT for Omnimic.

          At this point I hit the MS community and tried the fixes linked in my previous post, all to no avail.

          2) Thinking something had gone astray in my registry, installing apps and drivers, I figured I'd roll back to the clean install using the Win 10 "Reset this PC" function in the Recovery page of control panel.

          Once the roll back had completed I installed only Omnimic. No drivers or other software. Same error!

          So now I'm thinking there might have been a problem with the Win 10 boot-able flash drive? I created this from the MS support site for Australia; ie. the "en-au" version of Microsoft Support.

          If you search around the web I found about 5 different places in the Microsoft online ecosystem to do a clean install!

          3) Thinking that perhaps the flash drive is a dud or the "en-au" site might have a dud version of Win10 I instead headed to the "en-us" site and performed a "Start Fresh" clean install.

          This is what I would call an "online" install in that the OS runs the entire process and the tool has a completely different user interface.

          Once I completed the second, alternative clean install method, I did not install any drivers or software. Instead, this time I went to the Windows update section in control panel and allowed the OS to fully update.

          This took many hours and many restarts to complete until the update console reported the OS was all up to date.

          At this point, deep breath, I installed Omnimic from another fresh download from the Dayton website

          and………………….. ...….. SAME ERROR!

          I'm at work right now. Will try looking for the .dll's you mentioned when I'm home again and report back.

          Thanks again!

          Last edited by Maz; 06-21-2019, 10:38 AM.
          Klipsch KG 5.5 update.....


          • #6
            So happily I can report back that Omnimic is running again. Phew!

            Unfortunately I am not really sure why however. All I can put it down to is some kind of error in my clean install.

            I got home late Friday evening after watching the Western Force defeat Fiji in a cracker of a game and checked in on my computer for any updates.

            Windows seems to report "all up to date" but if you keep clicking the "check for updates" button in control panel it will often find something to update after a few tries...

            Anyway, when a few
            "check for updates" tries did not produce any results I figured "what the heck" I'll give Omnimic another whirl. And hey presto she loads up no problems!

            I didn't reinstall Omnimic since last try when it errored, I just opened from the existing desktop shortcut. Completely baffling how it might have righted itself?

            So this weekend was a wet one here and, figuring I was now a master of Win10 clean installs, I'd pop out to my local PC retailer and grab an SSD HDD to up my machines performance.

            Using my previously created USB Win10 boot disk I loaded the new SSD up with a clean install. Allowed the machine to update all the way up to version 1903, installed Omnimic and she's still working great.
            Klipsch KG 5.5 update.....


            • #7
              Happy to hear you got it running. Thanks for reporting back.
              Parts Express Engineer