No announcement yet.

Asus Tinker Board Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Asus Tinker Board Problem

    I have a curious problem with an Asus Tinker Board, probably the wall wart power supply, perhaps someone can explain this, or confirm what I suspect. The T-Board works well in my office at school inside the Machine Shop, with a monitor, keyboard and mouse, and Ethernet, no problems. It seems promising for playing music. I'm using the Android OS.

    At home, with no peripherals, it boots, but dies a few seconds afterward, although the red LED remains on. I have the recommended NorthPada wall wart 5V 3A power supply. Checking the few T-Board forums power supply problems are common, given the micro USB connector is rated for 1.8 Amps, and the board draws that and more when peripherals are connected. The T-Board seems well regarded despite this problem, SD card and OS problems along with little support from Asus. Given it costs less than $60 it is impressive.

    At school power is supplied by Central Maine Power, at home, Emera Maine. Both companies have problems during storms, and both have aging generation plants and transmission lines. I've checked the voltage at home at a 119.5V. I haven't checked at school yet. I suspect Emera power fluctuates more than Central Maine power. This may be enough to put the T-Board to sleep, given it supposedly has a very sensitive self protective circuit.

    I'm thinking of ordering a TEK power supply to connect to the 2 5V GPIO pins and ground pin. This was suggested on one of the forums.

    Any suggestions are appreciated.

  • #2
    I have used my Tinker with a wall wart supply and have had no power issues, though I am not running any peripherals, just the Tinker with Volumio software plugged into my DAC. Sounds like you are running the same wall wart supply at home as you are at work. Very curious. I know that certain OS versions have had some issues. Does it run in your office with no peripherals? I would try some other locations, too. Good luck. At any rate you can't go wrong with a better power supply. Ebay has some Chinese made supplies for $60 or so.


    • #3
      At the office I had two monitors running, a 7" R-Pi Touch Screen and a larger flat screen, this was accidental, as I forgot to remove the HDMI cable after attaching the T-Board to the R-Pi Touch Screen. I had a mouse/keyboard, SD card/USB drive and the 3.5 cable plugged into the audio out/mic in jack as well.

      At home, I had only the R-Pi touch screen connected. In both locations I used the same NorthPada PSU.

      I checked the house receptacle voltage around 9:30 AM, it was 119.5V, at about 12PM, 121.5V. I plan to check it over the next day or so, then call Emera Maine Monday and ask how stable it should be. I suspect our power supply is not as stable as it ought to be.


      • #4
        Have you tried running it at school with nothing attached? Maybe the firmware is looking for a keyboard and hanging. Could always try adding keyboard, mouse, monitor at home and see what it does.

        I doubt the power supply is at fault if it is a switching supply, as they are typically tolerant of quite large swings.


        • #5
          I had initially started it with the keyboard and mouse dongles, these are older than the single dongle I use in the office, and the SD/USB drive. The only change is I had soldered in the 2 S/PDIF pins and connected the S/PDIF cable to the amplifier. The solder joints look good.

          After it shut down the first time, I disconnected everything, and started it again with the same result.

          I plan to try it at the office Monday. I don't know what the R-Pi Touch Screen draws for current, but it may be enough to bring the total close to 3 Amps., and perhaps that is sufficient to shut it down. From what I've read the T-Board is very sensitive to PS problems.


          • #6
            Hey Tim:

            ​I've checked my voltage coming in, in the past, and again just now. 119.8v Not too far off from you and the basement system is sounding really good!

            ​I'll be curious to hear what you measure at school. Mark


            • #7
              I am thinking it is the OS and peripherals and not the power supply. How large a micro SD card are you using? For some reason my Tinker would not operate Volumio properly on a 8GB card but runs perfectly on a 16GB card. Hmmmmm. Also, there is a brand new version of the Tinker Board out where they updated some of its issues.


              • #8

                I just checked it again, 120.9-121, an hour ot so ago 122. I'm using a fairly new Klein multimeter.

                It will be interesting to see what it is at MMA. A few weeks ago two contacts on one of the shop transformers were loose and arching, occasionally shutting down the entire shop. That's about what we expect in Downeast Maine.


                • #9

                  It's a new Sandisk 16GB card, formatted and flashed with Android, which has worked better than Debian, which I updated. Everything but the S/PDIF connection worked surprisingly well at the office over the past week. Perhaps I have a marginal PS, the board cut out a few times before, now that I think of it, when I started using it 2 weeks ago, but it rebooted and seemed stable. A new T-Board and PS are on the way, perhaps they will make a difference.

                  Despite the problems, this SBC seems very promising.


                  • #10
                    Yes, it is superior to RPi, which also has a new unit out, but does not have the level of support. It's fun to play with and DIY with. When you get the new one, try running Volumio on the old board.


                    • #11
                      I use Moode with a R-Pi with the IQaudIO DigiAmp+ on the campus network. I don't have a home network because Broadband it's not available where I live. Moode works well about 2/3rds of the time given the campus network isn't all that good. I'd try Volumio but suspect it wouldn't do any better than Moode, given the network situation.

                      The Tinker Board interests me as a source for music. The Touch Screen makes a compact unit, and if the sound is as good as is claimed, and this seems likely from what I've heard so far, it will be worth the trouble.


                      • #12
                        The problem seems to be the Android OS, although, the Touch Screen was working before I left the office Friday. I suspect because I booted the T-Board with a second monitor, the Touch screen worked too.

                        Once running, the sound was heavy in bass, very muddy. I've since connected the T-Board analog out to a MiniDSP and Sure 4 channel amp. The sound is now quite good.

                        I've also flashed the Armbian OS, so far this has booted correctly with the R-Pi Touch Screen, the mpv player seems intuitive, files play easily, and the sound is good, probably as good as the sound using the R-Pi and IQaudIO DigiAmp+, although, I don't have both running currently through the same speakers, so I can't make a careful evaluation. Seems promising for a $60 SBC. I plan to try this using the S/PDIF out to a better amp at home.


                        • #13
                          The sound through a good amp and speakers is about as good as with a DVD player via HDMI through the same amp and speakers. No S/PDIF yet, there is probably a setting I'm missing, or a code modification.

                          Armbian works well, the Touch Screen even responds to touch, but is limited. It's unfortunate and surprising Asus isn't supporting this SBC, it is well designed, except for the USB power port. Good thing others are taking on writing code and working through problems.