Announcement

Collapse
No announcement yet.

Bi-color LED replacement help please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • marvin
    replied
    Thanks for the info, guys. Now I know what it is there for.🙂

    Leave a comment:


  • fpitas
    commented on 's reply
    Exactly, what you, Tom and Bill said. More info on the general subject here: https://sound-au.com/cable-z.htm

    Rod's schematic shows the output L-R network. Note that as time marches on, output transistors' maximum frequency of operation is going up (Google ring-emitter transistor if you're curious). Now it's common to have unity gain beyond 50MHz. That's great for performance but now RF becomes even more of a concern. The transistor can (and will) oscillate near its unity gain frequency when presented with a capacitive load.
    Last edited by fpitas; 02-10-2022, 10:23 AM.

  • PWR RYD
    replied
    It is called a Thiele network. It decouples the amplifier's output from high speaker cable capacitance at very high frequencies. It also blocks any RF energy picked up by the speaker cables (think of them as radio antennas) from getting back to the amplifier's input through its feedback loop.

    Leave a comment:


  • billfitzmaurice
    replied
    It's not a Zobel as we know it in crossovers, but it does provide a minimum impedance load at ultrasonic frequencies, in the event it's used with a speaker that has very low impedance in that range, like piezos.

    Leave a comment:


  • tom_s
    replied
    Marvin, I'm a little late to this thread, but glad you got the amp fixed. I never would have guessed the leads had been swapped.

    On the inductor wrapped around the resistor - it's a Zobel network to keep the circuit from going into oscillation. I was curious to learn more (and done with my project at work today) and found this thread at DIY Audio that explains it.

    https://www.diyaudio.com/community/t...output.346796/

    Leave a comment:


  • marvin
    replied
    your teacher side is showing Tom LOL

    Leave a comment:


  • tomzarbo
    replied
    Cool, all's well that ends fixed!

    That would be a parallel LR circuit if it were a speaker... don't ask me what it does in an amp, though.
    Maybe just wired that way to save board space or keep it more compact?

    See Marvin... when a resistor and an inductor love each other...

    TomZ

    Leave a comment:


  • marvin
    replied
    Click image for larger version

Name:	PXL_20220203_224426399.jpg
Views:	185
Size:	311.9 KB
ID:	1482420
    SOLVED IT!!

    Thanks for trying to help Francis and Tom. You prompted me to do a little more investigation. I have two of these amps so I compared the wiring of both LED harnesses some time ago and they appeared identical. So I tested voltage between the two outer leads and the center common lead. Both were 1.5-1.9 volts during boot up, and then the red one remained on at 1.5 volts during normal operation while the green one went low.

    Learning they used similar voltage gave me confidence to reverse the LED connection--rotated the LED in its mounting board. VOILA! All is good now! Someone must have tinkered with it since it left the factory, I'm sure that would not have passed QC.

    Now I need to find a cover for this amp (it's missing).

    Thanks again,

    Marv

    PS...I'm curious why Creek wound copper around this resistor? They are terminated on the same foil pads. They did this in only two locations in the amp.

    Click image for larger version

Name:	PXL_20220203_165131811.jpg
Views:	180
Size:	553.1 KB
ID:	1482422

    Attached Files

    Leave a comment:


  • fpitas
    commented on 's reply
    Even a part number for the LED, as long as it's not proprietary (and hence meaningless to us).

  • tomzarbo
    replied
    Is there any way of getting ahold of a schematic for the amp? I'm not saying I could make heads or tails of it, but maybe someone here would be able to.

    There are three leads to the LED? Can you put a multimeter on each lead coming from the amp with the LED disconnected to see what each is doing voltage-wise, and when?

    TomZ

    Leave a comment:


  • fpitas
    replied
    Generally speaking, the operating voltage for a particular color LED is similar to others of the same wavelength. That LED may have internal resistors though, and be made to connect directly to power.

    Leave a comment:


  • marvin
    started a topic Bi-color LED replacement help please

    Bi-color LED replacement help please

    Some of you may recall the Creek integrated amps I brought to Iowa last October. One seemed to be stuck in protect mode--the indicator lamp turned on mostly red with a small spot of yellow, then went full red when the boot sequence completed with a click. I finally determined the amp is not in protect mode and is working fine. However, the LED should start up yellow and turn green after start up. Red normally indicates a fault. I think the led is defective or may have been replaced with the wrong type?

    I'm thinking a bi-color 3 lead red/green replacement LED should fix this. Red+green light produces yellow, correct?

    Are there any electrical parameters I need to watch for or will any RG bi-color LED do the trick?

    Note: If I unplug the LED and turn on the amp, it turns on immediately without the normal protect sequence delay. Somehow the presence of the LEDs in the circuit defeats the start up delay when absent from the circuit. That is why I wonder if there is anything special about this LED.

    Thanks for your help,
    Marv
Working...
X