Announcement

Collapse
No announcement yet.

What's wrong with my C-notes?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What's wrong with my C-notes?

    Hey guys took a pair of cnotes I finished building up outside to measure, seems I'm having a big distortion issue in the mid range, I assume it's from something wrong with my xover. Both speakers show the same issue. I'm also getting a huge HF shelf that makes them sound extremely bright. I have to pull the xovers out to for some pictures but, yeah, any idea what's going on?


    Site is not letting me upload pictures, here are some links.

    https://imgur.com/zzqH5KI

    https://imgur.com/zgMvOjH

  • #2
    Xover pics, not the best. Everything looks right to me at least.

    https://imgur.com/VplahCw

    https://imgur.com/ugT5OYU

    https://imgur.com/L0JXtDH

    Comment


    • #3
      Took some measurements of the drivers themselves out of box, no xover, then with xover, distortion is fine. So could it be from the cabinet?

      Comment


      • #4
        When the drivers and crossover have been ruled out it's either the cabinet or interaction between the woofer and tweeter. Measure it with just the tweeter.
        www.billfitzmaurice.com
        www.billfitzmaurice.info/forum

        Comment


        • #5
          Just the tweeter appears to be fine distortion wise. The cabinet has no dampening inside at the moment, still waiting on a sheet of sonic barrier to come in.

          Comment


          • #6
            There's not enough context in the pictures to tell if it's wired correctly. You might try drawing the crossover based on how you have you parts wired without looking at the crossover diagram. I like a node diagram. Then compare to the original.
            John H

            Synergy Horn, SLS-85, BMR-3L, Mini-TL, BR-2, Titan OB, B452, Udique, Vultus, Latus1, Seriatim, Aperivox,Pencil Tower

            Comment


            • #7
              I think there may have been some issue with my measurement rig at the time of those measurements, I can't seem to be able to repeat them, not even close. Distortion looks normal now.

              The steady rise from 7k up though, what is up with that? Makes the speaker crazy bright. Don't see it in PE manual or ASR review. The center does have it though, did the tweeter change?

              I contacted PE about the rise, my speculation is that, that's just how the speakers perform and the provided response by PE is just not accurate.

              Comment


              • #8
                A rise from 7kHz up isn't a bad thing, it compensates for the effect of equal loudness. If it's too bright for your taste that's what EQ is for.
                www.billfitzmaurice.com
                www.billfitzmaurice.info/forum

                Comment


                • #9
                  I disagree, this rise is quite bad and very fatiguing. The speaker is exhibiting "tear your head off" levels of treble for me. I also don't feel I should have to EQ this, as the speakers should be meeting the provided response, the shelf is IMO beyond the realm of acceptable deviation. If this is just how they are I simply didn't get what was advertised.

                  It seems this issue has already been documented here, so PE should know. I'll keep this to my chat with PE for the moment and if any updates come through on their end I'll share them.

                  https://techtalk.parts-express.com/f...er-kits/page15

                  Some more measurements.

                  Unfiltered vs. Xover - https://imgur.com/9rPc5i3

                  Manual's response trace vs. mine - https://imgur.com/VCBJVPN


                  Last edited by joshshetter; 08-29-2022, 06:49 PM.

                  Comment


                  • billfitzmaurice
                    billfitzmaurice commented
                    Editing a comment
                    Your unfiltered versus filtered responses shouldn't look like that. They should be very similar above the crossover frequency.

                  • fpitas
                    fpitas commented
                    Editing a comment
                    What Bill said. You must have a crossover oopsy.

                • #10
                  Here's my xover with some traces on how it's wired. This is the first one I've done without a premade pcb from Matt, dangit lol.

                  https://imgur.com/dvpgtJq

                  Comment


                  • #11
                    How much have you played them? I'm lazy and never break in the drivers enough before I build the crossovers so they sound like absolute [email protected]&%# until they settle in. The first few hours is a horror show of "what have I done??" until it all chills out... though sometimes i find that a tweeter is rubbing the voice coil. I've had to replace a couple diaphragms due to that. Fortunately I live near PE so I can hand test the cone drivers at least.
                    I'm certainly not good at this. Just stubborn enough to keep going.

                    Comment


                    • #12
                      Driver break in? Really? Didn't expect to see that here. Respectfully no, that has nothing to do with my issues.

                      PE support suggest break in and I just rolled my eyes....

                      Comment


                      • #13
                        Driver break in is real, but it's also slight, and it mainly occurs with drivers that have a long excursion, which is to say woofers and subs.
                        www.billfitzmaurice.com
                        www.billfitzmaurice.info/forum

                        Comment


                        • #14
                          I took the xover apart and rebuilt just the tweeter circuit, it's in a straight line so no room for error here (unless I am just fundamentally missing something here). Measures the same as before.

                          Green is before, Red is the rebuild.

                          https://imgur.com/hAgPcGW

                          Here's a pic of the circuit.

                          https://imgur.com/X9yqHTb

                          See anything wrong there?

                          Comment


                          • duanebro
                            duanebro commented
                            Editing a comment
                            Can you take a better picture of the crossover? Very difficult to see what is going on.

                        • #15
                          Is that the 6ohm resistor under the tape there on the left?
                          Constructions: Dayton+SB 2-Way v1 | Dayton+SB 2-Way v2 | Fabios (SB Monitors)
                          Refurbs: KLH 2 | Rega Ela Mk1

                          Comment

                          Working...
                          X